Many licensed and some free of cost script-driven applications have encrypted code, which isn't human readable. The reasoning behind this is to stop the reverse engineering and the unauthorized use of such apps. Among the most popular file encryption software tools used for this specific purpose is called Zend Guard and it's widely used as it can be used to modify all PHP 4 or PHP 5 code. The sole way for the encrypted files to work properly on a web server afterwards is when a second tool called Zend Optimizer is there. In case you would like to use any kind of paid web software which requires Zend Optimizer, you need to ensure that it's installed on the server where you will host your website. In addition, websites which need the instrument will perform better since their code is already precompiled and optimized, which means that it's executed more quickly.

Zend Optimizer in Cloud Hosting

Zend Optimizer comes with all servers which are part of our innovative cloud web hosting platform. No matter which Linux cloud package you select, you'll be able to activate the software tool so that any script app which requires it will work perfectly in your account. Using a handy instrument in the Advanced section of the Hepsia Control Panel that is included with all the website hosting accounts, you will be able to activate and deactivate different options with a single button. Zend Optimizer will be one of them, so even if this happens to be your very first hosting account ever, you won't have any issues. In the exact same area you can also pick the PHP release for your account - 4 and several versions of 5, and each time you switch to one that you have not used yet, you can activate Zend Optimizer for it with a single click. As our platform enables you to use multiple PHP versions at once, more experienced users can enable the instrument for an individual website with a php.ini file in a specific domain folder as well.

Zend Optimizer in Semi-dedicated Hosting

Zend Optimizer is featured on all of the servers that comprise our cluster web hosting platform, so you are able to use it for all of your script-driven applications with any of our semi-dedicated server plans. It'll be available all the time even when you switch the PHP version for your account because our feature-rich platform allows you to select from PHP 4, 5.2, 5.3, 5.4 and 5.5. Both changing your version and activating Zend Optimizer for the new one takes just a few clicks in the PHP Configuration section of the Hepsia hosting Control Panel which is used to control the semi-dedicated accounts. What's more, you may also employ a different release of PHP and enable or disable Zend for each individual site that you host in the account. This is possible by using a php.ini file in a domain folder with a couple of lines of program code inside it. If you don't have previous experience and you aren't sure how to do that, our 24/7 tech support can assist you.